How Multi Website Works in Flectra


Hi ,
Can you specify or any video for multi website configuration in Flectra?
Already configure flectra in locally but there is no doc or video available for this ,any help link for this configuraton?



I’m not an expert, but I started to figure out how to make a multiwebsite with Flectra.

You have this video available that will help:

For a use on a remote server, and not local as shown here, mount a server using nginx, and simply point the DNS of your different domain name on your server IP.

For removing the port from the different URLs, I struggled a bit, but finally it’s quite easy with nginx.

Find the default file in /etc/nginx/sites-enabled/ and modify it this way:

server {
listen 80;
server_name _;

    location / {
            # First attempt to serve request as file, then
            # as directory, then fall back to displaying a 404.
    proxy_pass http://localhost:7073;
    proxy_http_version 1.1;
    proxy_set_header Upgrade $http_upgrade;
    proxy_set_header Connection 'upgrade';
    proxy_set_header Host $host;
    proxy_cache_bypass $http_upgrade;


Then everything works for me.

The only problem I have is that it’s not a fully independant multi website.
As shown in the vid, the content, pages, etc… are independant, but logo, contact e-mail, company name is unique and shared through the differents website.

In my case that’s a problem. I have a company that import and sells different brands. Each brand has it’s own URL, own website, own logo, and its own contact e-mail. But so far, I can’t make these 3 different website have different logo and different e-mail and I’d like to change the company name for the brand name.

Maybe there is a trick to achieve that, but didn’t find it so far.


It looks like you could use the Saas modules from Odoo.


@davef_cook: actually no. If I understand well, the Saas module is made to really separate instance.

In my case, I have a company that imports 3 differents brands. I need three different websites, 3 different url, mailbox, etc…
3 differents identities for the public, but the company behind is the same. There is one backoffice, one accountancy.

And ideally, I would need 3 B2C shops totally independant, and 1 B2B shop that sells everything for my pro customers who buy products from these different brands.


I have also tried to make the multi site work. In our case we would like to make 2 web sites where one is the main company site, and the other is the site for a division of the company with another logo. (maybe another theme too).

  • I have tried to set this up and it was not very hard once I got the right DNS set up and Apache configuration for each site. Then in flectra set the appropriate fully quantified host name for each site.

  • when you create your 2nd web site, flectra seem to copy some things over from the main site to get you started. I then worked to edit this material for the division site.

  • however I ran into this problem where even if I specified a different logo and favicon for each website, this never seems to work. No matter what, the last logo that I entered or added seems to appear on BOTH websites. In the configuration UI each site has it’s own logo image.

I was wondering is this a bug, or am I doing something wrong.

Also I tried to install the flectra-community module which allows you to have multisite and different themes for each site. Every time I try to install this module all I get is 500 error on the site.

Anyone else had similar experiences or found solutions? Thanks!


Ping. Hi, anyone else have this issue and can comment??


Hi Whotopia,

Sorry I can’t help but have the same problem with multi websites. I can get the dns working but it appears that, even through there are separate web sites, they share the same social media information, logos etc. Editing the one web site simply updates the information on both web sites.

I am not sure if it was when I was creating multi websites or earlier when I was less familiar with Flectra but I also have 2 companies now even through mutli company and multi branch is not enabled.