Postgresql 10 reaching EOL


#1

So I just got an update on Debian about postgres 10 being end of life.

The current docker image is based on 9.6 which is pretty old at this stage. There is a need to refactor the database code to be compatible with newer versions of postgres in order to make sure backups and recovery function correctly. Soon the older versions of clients and libraries will be deprecated.

One pretty important reason to move to 11 is the ability to use stored procedures. You can read more about them here