What is the current recommended Postgres version?


#1

Hi guys!

What’s the latest Postgres version you’d recommen when running the latest Docker image

The image description has postgres:9.4 but what about newer versions?


#2

I guess newer versions should not have any problems (at least up to 10 series). @parthiv on this ?


#3

Yes not a problem for me as we are already testing with both v10 and v9. 6


#4

Alright the, thank you.
Right now my test Installation is running on 9.4.
Is there documentation I can consult when upgrading to a higher Postgres Version?


#5

You should check PostgreSQL documentation, as it’s not really Flectra related.


#6

I assume that the PostgreSQL version number does not matter for Flestra
So?


#7

FWIW, I’m on 10.5, without any issues. That is, no issues at database level.


#8

You should have no problem with 9.x or 10.x versions.
8.x versions are slower and not supported anymore by upstream PostgreSQL foundation, so avoid them.
For v11, it’s too early to affirm that there is no issue, as I guess few people have tested it with Flectra.


#9

What are the advantages of version 9 over version 10 in using Flstra?


#10

IMHO stability,being the default on your Linux distribution… But 10.x brings many improvements (including performances related ones) so if you can, I would say go for it !


#11

Then, maybe, in the installer to make it possible to choose the available versions of PostgreSQL?


#12

I see that the DEB package installed from the Docker image today requires the postgresql-client-9.6. Maybe it’s the actually officially supported version, but I upgrades my Postgres version to the major version 11 and all functions and creation of new databases works OK.
The unique failed dependency is the pg_dump required application that is installed in /usr/bin/pg_dump from the postgresql-client DEB dependency that makes errors for make backups, restore and duplicate databases.
The solution is possibly to upgrade this dependency to postgresql-client-11. I don’t have checked this change yet.


#13

I see that flectra:v1.6.2 and flectra:v1.6.3 includes pg_dump 10.10 because I can say that the max supported version of postgres is Postgres 10.10 for these versions and I was created a new instance installing postgresql-client-11 and it’s works without problems. I can make backups using Postgres 11 now.


#14

Finally, I see that the GitLab CI of the origin Flectra repository has reference to make tests over Postgres 11.


#15

Where to get the Flectra installation script with Postgres 11 or Postgres 10?