What version of wkhtmltopdf will Flectra work with?


#1

I was wondering what version will Flectra work to generate PDF on the fly, is it:

wkhtmltopdf version 0.12.1 ? or wkhtmltopdf version 0.12.3 ? or wkhtmltopdf version 0.12.4?


#2

Hi,
I think Flectra will be using wkhtmltopdf version 0.12.1 .


#3

Hi @NIyasRaphy,

Why get stalled on old vesions and work with newest that has security patches?

For example 0.12.3.x has openssl patches and it have been optimized as well.

I’ll be testing those versions (0.12.3.x and 0.12.4) to see how it goes.


#4

See the installation process described here ->
https://gist.github.com/flectrahqadmin/d4c827577b3251a9505d3b697b1068be

Here you can see both the versions 0.12.4 and 0.12.1 . We will get more clarification from the Parthiv


#5

Thanks, I will give it a try using Debian and also using Centos 7 (This is the one I commonly use).


#6

0.12.4 is not supported due to number of technical reason and glitches. we may have to do lot of fixes and rework in order to support it. For the time being it’s not in our roadmap.


#7

Hi @parthiv,

So It means that version 0.12.3.x should be supported?


#8

no, we are not moving away from support of 0.12.1


#9

I’m currently using wkhtmltopdf v 0.12.5 with Flectra for testing and O v10 in production and it’s working fine without issues.


#10

https://gitlab.com/flectra-hq/flectra/snippets/1712996#L9 Flectra installation refers to install the wkhtmltopdf 0.12.2.1 while in the Flectra Install Doc recommends to install 0.12.5. I believe the 0.12.5 is the latest and is supported now :+1: