Why the rest api seem to not working?


#2

You need to use --db-filter parameter while Starting the server. Please read the module documentation.


#3

Tks for reply , could you give me a example for the db-filter , tks!

and I set the db-filter in flectra.conf as follow …

but it return the same result

Is there something to setup in otherplace ?


#4

Is really no one can answer me this question?
:disappointed_relieved:


#5

you can follow this video

https://www.youtube.com/watch?v=A_5EyLYkl3Y


#6

I was completely according to the set of documents to do, but still can’t get the right result? For example in the video can’t mention "db - filter Settings. I also posting my config file ,it should be able to judge whether to set up the right, but is not directly in the face of himself. tks!


#7

You have used a dynamic domain filter which depends on the url of your instance. Can you try with a static database filter and check.


#8

I completely is according to the document, according to the video, in accordance with the instructions to test, but why still can not get the correct results? Now attach our server Settings and start the script has the test result, hope to get the real solution and solutions, exactly what went wrong, now is a good idea.


#9

Run this

sudo su flectra

./opt/flectra/flectra/flectra-bin --config=/ect/flectra/flectra.conf --db-filter yourdatabasename -d yourdatabasename

and then try to connect via REST API


#10

HI,

Tks for reply

Does REST-API not support the db - filter, dbname parameter is written in the config file?


#11

It does support that as well but do you know what you have used as database filter in your config file?


#12

Hi, Parthiv

About REST-API ,I still can not get the properly result

  1. Attachment is the command and configuration details I launched.

  2. But the result is still 400. . .


#13

Your default flectra service seems to be still running.

sudo service flectra stop

And then run the commands I gave.

Use

ps -ax | grep flectra

To see the running instances of Flectra.


#14

hi

here is the ps -ax | grep flectra … detail


#15

Do you still have db filter in your config?


#16

Attached to the flectra.conf file


#17

There is no attachment


#18

i also have the same problem, already set the db_name and db_filter in flectra_conf but the REST post result always wrong dbname…


#19

found the problem, by the default OAuthlib is not installed, so I install OAuthlib and REST API is working…


#20


Getting 404 with while accessing REST api with flectra 1.6


#21

Hi!
For me http://localhost:7073/api/auth/get_tokens is working and if I do not set access_token in the header of http://localhost:7073/api/res.partner I’m getting the proper “access_token_not_found” error but if I set up access_token (which I’ve received through /auth/get_tokens endpoint) in the header, Postman gives me ‘Could not get any response’ and nothing appears in the error/infolog of flectra. Could someone help me with that?